10/1 Lapel Outage due to Duke Energy
Incident Report for Fiberhawk
Resolved
Duke Energy completed their work and all services are operational.
Posted Oct 02, 2024 - 09:07 EDT
Identified
Duke Energy is replacing poles in the Lapel Area today 10/1, services will be interrupted and should last about 4 to 6 hours. More updates to follow.
Posted Oct 01, 2024 - 10:47 EDT
This incident affected: Lapel, IN.