We experienced an equipment failure last night during maintenance. If you are still experiencing service issues please contact our office at 765-922-7917.
Posted Apr 02, 2025 - 08:16 EDT
Update
Technicians are still working on replacing failed equipment.
Posted Apr 01, 2025 - 08:15 EDT
Update
Techs are onsite and working to replacing failed equipment.
Posted Mar 31, 2025 - 13:52 EDT
Update
Emergency maintenance planned for 2PM on 3/31 to resolve intermittent issues in service.
Posted Mar 31, 2025 - 13:02 EDT
Identified
Technicians have identified the issue and are in the process of resolving the issue.
Posted Mar 31, 2025 - 12:52 EDT
Investigating
We are aware that some customers are experiencing issues with service as of 8:30 this morning. Technicians are investigating the issue and working towards a resolution. Customers may experience intermittent service during this time.