Kirklin

Incident Report for Fiberhawk

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 14:54 EDT

Investigating

We had an equipment issue that we quickly identified and everything should be good now. If you continue to have issues with your service, please power cycle your ONT and router. Thank you
Posted Aug 26, 2025 - 12:15 EDT
This incident affected: Kirklin, IN.