Our technician identified a power issue affecting equipment in our Sheridan service area. The problem has been resolved, and phone and internet services have been restored.
If your internet is still not working:
1. Please reboot all equipment (ONT, router, etc.). 2. If the issue persists, contact our support team at 765-922-7916.
Thank you for your patience!
Posted Sep 08, 2025 - 21:53 EDT
Monitoring
Issue resolved. If you are still experiencing problems, please power cycle your equipment. Thank you
Posted Sep 08, 2025 - 21:51 EDT
Identified
We have identified a problem in Sheridan and are dispatching a technician to resolve the issue.