6/24 Outage (Multiple Service Areas)

Incident Report for Fiberhawk

Monitoring

Our team has been working on a fix for those affected by this outage, we have received word from the team that is working on this that customer's service should be up now. We are continuing to monitor the results and will continue to update as we know more.
Posted Jun 24, 2026 - 10:14 EDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2026 - 09:27 EDT

Update

We are continuing to investigate this issue. Customers may notice slower speeds and connectivity issues regarding apps/services.
Posted Jun 24, 2026 - 07:54 EDT

Investigating

We are currently investigating this issue.
Posted Jun 24, 2026 - 07:53 EDT
This incident affects: Sheridan. IN, Kirklin, IN, Frankfort, IN, and Frankton, IN.