Swayzee Area Wireless Outage

Incident Report for Fiberhawk

Resolved

Power issue resolved.
Posted Jun 16, 2025 - 09:38 EDT

Investigating

We are currently investigating this issue.
Posted Jun 14, 2025 - 11:21 EDT
This incident affected: Swayzee, IN.