Swayzee/YTCI E-Mail

Incident Report for Fiberhawk

Update

For now, access to webmail for both domains can be accessed by mail.ytci.com
Posted Jun 18, 2026 - 08:17 EDT

Investigating

We are currently investigating the inability to access swayzee.com and ytci.com webmail. You may need to click advanced and continue to the site if you are warned about proceeding depending on what internet browser you use. We have a ticket in to get this resolved ASAP.
Posted Jun 18, 2026 - 08:14 EDT
This incident affects: Swayzee, IN and Yeoman, IN.