Frankton Power

Incident Report for Fiberhawk

Monitoring

The issue has been resolved, and we are continuing to monitor as customers come back online.
Posted May 14, 2026 - 13:41 EDT

Update

We are still working to fix this issue, more updates to follow.
Posted May 14, 2026 - 12:52 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2026 - 09:01 EDT

Identified

A technician of Fiberhawk discovered that an electrical crew in Frankton has commercial power down to our facility to replace a pole. Service should restore once they are done moving the lines and turn the power back on. We apologize for the inconvenience.
Posted May 14, 2026 - 09:01 EDT
This incident affects: Frankton, IN.