VOIP Down
Incident Report for
Fiberhawk
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Jun
01
,
2026
-
14:57
EDT
Identified
We are currently experiencing a wide outage for our VOIP service due to a 3rd party. We have a ticket in with them but do not have an ETA.
Posted
Jun
01
,
2026
-
14:34
EDT
This incident affects: Sheridan. IN, Kirklin, IN, Frankfort, IN, and Frankton, IN.
×
Subscribe to Incident
Subscribe to updates for
VOIP Down
via . You'll receive .