Swayzee Phone Service
Incident Report for
Fiberhawk
Update
We are continuing to investigate this issue; we have not received any updates from our third-party provider.
Posted
Aug
24
,
2026
-
16:18
EDT
Update
We are continuing to investigate this issue.
Posted
Aug
24
,
2026
-
10:27
EDT
Investigating
We are aware of some calling issues receiving and making calls in our Swayzee service area. We are investigating.
Posted
Aug
24
,
2026
-
08:30
EDT
This incident affects: Swayzee, IN.
×
Subscribe to Incident
Subscribe to updates for
Swayzee Phone Service
via . You'll receive .