We are aware that due to the scale of the ongoing project that services are still impacted in certain areas, so far we have been able to make progress and we've gotten the updates below from various teams:
Contractors have repaired their splicing issue. Our technicians have resolved individual issues at customers’ homes. Our IT department has rebooted and checked all relevant equipment.
Unfortunately, we are still experiencing an issue that our team is actively working to resolve. At this time, we do not have an ETR, as additional team members are currently enroute to assist.
Rest assured, we are doing everything possible to restore service to everyone as quickly as we can!
Posted Mar 11, 2026 - 13:09 EDT
Update
We are still working on maintenance in Sheridan, there appears to be an issue with the fiber that supplies service to multiple customers. We are working as quickly as possible to get this resolved so that services come back online for affected customers. We will continue to update as the situation develops.
Posted Mar 11, 2026 - 09:32 EDT
Monitoring
Sheridan maintenance is running over. We are working to get everything up and running.