4/2 Swayzee Performance issues

Incident Report for Fiberhawk

Resolved

The incident was resolved early this morning.
Posted Apr 03, 2025 - 02:00 EDT

Identified

We are aware there are some customers that are experiencing issues with slower speeds. Technicians have identified the issue and are working towards a resolution.
Posted Apr 02, 2025 - 17:02 EDT
This incident affected: Swayzee, IN.