Contractors finished the repairs Saturday evening and services restored. Any customers that are noticing lingering issues with their service should contact our office at 765-922-7917.
Posted Jun 08, 2025 - 07:00 EDT
Update
Technicians arrived on site and identified that the issue is due to the HVAC system not supplying cool air to the affected equipment. Contractors have been contacted and are working towards making repairs.
Posted Jun 07, 2025 - 09:54 EDT
Identified
We have identified the issue affecting some customers in Sheridan that is causing service to go down. Technicians are en route and more updates will be provided once we know more.